Dec 16, 2017, 06:48 PM

News:

Like our community? Please +1 our modpacks here and here


[Survival] It's time to talk 1.13

Started by Towelie, Dec 06, 2017, 02:11 PM

previous topic - next topic

0 Members and 1 Guest are viewing this topic.

Go Down

Towelie

Dec 06, 2017, 02:11 PM Last Edit: Dec 06, 2017, 02:15 PM by Towelie
It's time to talk 1.13 and what this will mean for Survival.
At the very least this will mean at least ~30% of our current plugins becoming broken, this will include some of the older premium shop perks. Please note that we will not offer any refunds, but after maximum ~2 months after updating, if we are not able to bring that perk back, we will offer you premium shop credit so you can get something new.
It's not really clear what plugins will break and it's not really possible to predict which plugins will break.

Quote from: SpigotMC
Dubbed the technical update, Minecraft 1.13 will be the next major version of Minecraft to be released. This release will include a lot of long awaited changes and refactorings to both the client and server, and as a result is expected to be the largest CraftBukkit/Spigot release since 1.8, and the largest Bukkit (API) release ever. We have already spent around 50 hours on snapshots and are starting to get a pretty good (although purely speculative) idea of what the impact will be to plugin developers and server owners.
Because one of the primary goals of the Bukkit API is to provide a stable interface for plugins across a variety of platforms and versions, changes have to be made with the right balance between stability, featureset, and maintenance. With this in mind we have decided to target the following changes:

    Block type IDs will be completely removed
        This is a change which started to be implemented over four years ago, unfortunately there are still plugins out there using block IDs when they shouldn't be, including some fairly popular ones. Virtually every occurance of block IDs currently has an Material replacement available for usage right now. If your plugin, or a plugin you use exposes IDs in any form we strongly recommend you work to get it upgraded right away as this may be a somewhat involved process (albeit one that should have been done years ago).
    Block data values will be deprecated
        All instances of byte data values, and MaterialData usage will be deprecated. Although the byte data values have also been deprecated for a very long time, many of them do not currently have suitable replacements. As such we will be providing support for them on a best effort basis. This means that plugins using these APIs will (hopefully) run to some degree, but you should not expect complete or consistent support. We strongly recommend waiting for updated versions for the best performance and data...
This may mean that a ton of plugins will break, possibly even some essential ones like autoshop plugins and so on.
There is also the slight possibility that a full reset will be needed, but there is no conclusive information towards that yet.

I would just like to re-iterate that if the need arises, I will do what I believe best for Survival, and I will not listen to players, even if the vast majority decides a way or the other. For example if you guys vote for us to stick to 1.12 forever (in case we need a full reset), I will not accept that, because that would mean condemning SFT to a fast death. Obviously, I will do my best to listen to you for reasonable things, but ultimately, I am the custodian of this server and some times I have to take the tough decisions.

I don't know which plugins will break, I did inform @darknuju and @ColesyM to update their plugins and I will be talking to @fearthe1337 as well for that.

TL;DR version-> 1.13 is coming and will probably break half of our plugins. Be ready for stuff to not be the same, and for a lot of stuff to break (premium shop perks, autoshop plugin, etc). While we will indeed find a fix or replacement for this plugins it may be a while (I'm talking months from when 1.13 is out) in which we will have to stick with a minimalistic server.
Also, there is a low possibility that we will have to do a full reset with 1.13, in which case I will do it regardless of the desires of the community (because the only alternative would be remaining on 1.12 and that would condemn the server to death)


Follow me on Instagram (i post cool stuff) https://www.instagram.com/toweliewtf/
Psst, got a Nintendo Switch? Add me -> SW-6574-1607-3796

xQuicScopex✪

1.13 will BREAK 1.12 worlds according to devs, once a world is loaded in 1.13 it can never go back
The king of slime fun, donations, and grinders. Basically the best ever at making money.

Survival Sniper | SFT Patreon
Pocket Developer/Owner | B-Team JMod

blakus87

Could we not stay 1.12 u till the plugs are fixed and then update? Or am I being simple.
Survival Meanager
Patreon

Towelie

Could we not stay 1.12 u till the plugs are fixed and then update? Or am I being simple.
That would mean staying on 1.12 for months time in which we would stop receiving any new joins. Playercount decreases dramatically when you are a version behind, and seing as our playercount is already low, we can't risk that.


Follow me on Instagram (i post cool stuff) https://www.instagram.com/toweliewtf/
Psst, got a Nintendo Switch? Add me -> SW-6574-1607-3796

Towelie

1.13 will BREAK 1.12 worlds according to devs, once a world is loaded in 1.13 it can never go back
Link pls. I'm curious if that means that it will CONVERT the worlds or you simply cannot load a world whatsoever from 1.12


Follow me on Instagram (i post cool stuff) https://www.instagram.com/toweliewtf/
Psst, got a Nintendo Switch? Add me -> SW-6574-1607-3796

blakus87

Could we not stay 1.12 u till the plugs are fixed and then update? Or am I being simple.
That would mean staying on 1.12 for months time in which we would stop receiving any new joins. Playercount decreases dramatically when you are a version behind, and seing as our playercount is already low, we can't risk that.
That's fair.
Survival Meanager
Patreon

xQuicScopex✪

1.13 will BREAK 1.12 worlds according to devs, once a world is loaded in 1.13 it can never go back
Link pls. I'm curious if that means that it will CONVERT the worlds or you simply cannot load a world whatsoever from 1.12
I saw it on the mojang reddit so ill try to refind it, and according to it, it will convert your world over to 1.13 so itll work but if you decide to go back you cant (also advises having a backup of your world because can cause corruption)
The king of slime fun, donations, and grinders. Basically the best ever at making money.

Survival Sniper | SFT Patreon
Pocket Developer/Owner | B-Team JMod

TeraStorm

did someone say full reset?


I'll be Flaca to your Maritza daddy Emma <3

Mazeworker

I'd say just do a full reset... at least we can open The End and have that option open... ether way I'd still play.

reiner_13

#9
Dec 07, 2017, 01:46 PM Last Edit: Dec 07, 2017, 09:46 PM by reiner_13
Survival Elite
Former Survival Mod
Survival Lemon

Lucy_23x

LETS GATHER OUR ARMY AND STORM THEM

AHHHHAHAHAHAHAHAHAHAHAH

and also; how old are you? I've always imagined you as like a old irish man that drinks whiskey and screams at people to get off his lawn while sitting on a bench in the park. But I'm pretty sure that's not the case because if it was: 1. you're a pedophile and 2. you're a pedophile

George_Filos

Towelie when it becomes 1.13 don't update the server. It takes like 5 days to make all plugins work correctly
I love survival! :)

MrChanango

Towelie when it becomes 1.13 don't update the server. It takes like 5 days to make all plugins work correctly
But when the plugins would be corrupt, and we wait for the actual plugins to update by the devs, it becomes more like 5 weeks or more.
Owner of the legendary Wood4U!
Founder at ModMart!

Survival Mod - 12/30/16 - Survival JMod - 11/5/16 -
Survival Manager - 7/17/17

saywhat2365

1.13 will BREAK 1.12 worlds according to devs, once a world is loaded in 1.13 it can never go back
Link pls. I'm curious if that means that it will CONVERT the worlds or you simply cannot load a world whatsoever from 1.12
I saw it on the mojang reddit so ill try to refind it, and according to it, it will convert your world over to 1.13 so itll work but if you decide to go back you cant (also advises having a backup of your world because can cause corruption)
That's generally always the case anyway.

BluetigerESW

Towelie when it becomes 1.13 don't update the server. It takes like 5 days to make all plugins work correctly
Sorry to disappoint you, but it'd most likely take a lot more than 5 days lol
Don't be afraid to ask me any questions you have......I only bite when I'm hungry! ;)

Go Up